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.. Objectives I

Know the main two types of computer graphics
Know what is meant by tiff, tif, gpeg, png, eps, ps, etc ...
Know when and where to use each format
Know how to choose the correct resolution for every case
Know how to scan your images correctly
Know how to send your graphics to the publishers
Know some basic skills needed by every researcher
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.. Important Note I

Keep all your graphics in a separate folder in their original
editable format.
For example, if your graphs were created with excel, then keep
the original excel file.
If they were created with Inkscape or adobe illustrator, then
keep the original files created by these programs.
This will save your time, if you need to modify these files
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.. Short Message

...
Take This Short Message:

...1 For Bitmap image, stick to TIFF

...2 For Bitmap image with transparency, stick
to PNG

...3 For Vector image, stick to EPS or PDF
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.. Picture Versus Image

What is the difference between picture and image

Picture is the printed or drawn on papers,
While image is that found on computer monitor, stored
digitally or found inside my mind (mental image)
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.. Sorrow – Mahmoud Mokhtar
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.. Your Swiss Knife I

...1 Word processor
...1 Microsoft Word
...2 Open Office Writer (LibreOffice)

...2 Spread sheet programs
...1 Microsoft Excel
...2 Open office Calc (LibreOffice Calc)
...3 Gnumeric

...3 Image manipulation programs
...1 Adobe Photoshop
...2 Gimp
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.. Your Swiss Knife II
...4 Vector graphics editor

...1 Adobe Illustrator

...2 Inkscape

...5 Billiographic editor
...1 JabRef
...2 Bibus

...6 Desktop publishing (DTP)
...1 Adobe InDesign
...2 LYX
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.. What are Computer Graphics

The term computer graphics includes almost
everything on computers that is not text or sound.
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.. Color Systems I
.RGB..
......(red, green, blue) color system

.CMYK..

......
(cyan, magenta, yellow, black), used in all
industrial printers and some inkjet printers

.Note..

......

So, when sending your article to the publisher,
you have to convert your images from RGB to
CMYK system
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.. Color Systems I

RGB (red, green, blue) color system
CMYK (cyan, magenta, yellow, black), used in all industrial
printers and some inkjet printers
So, when sending your article to the publisher, you have to
convert your images from RGB to CMYK system
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.. Color Systems II
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.. Resolution I

Is the density of pixels
Sometimes resolution is described as density of pixels in length
unit (pixel per inch), in area unit (pixel per square inch, used
mainly in scanners and printers), or in the whole image
The latter i.e. is used mainly in cameras, for example a 3.1
megapixels, camera produces an image which is 2048×1536 =
3,145,728 pixels or 3.1 megapixels.
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.. Pixel: I

Is the smallest single component of a digital image
Each pixel has its own address.
The address of a pixel corresponds to its coordinates (x and
y). Pixels are normally arranged in a two-dimensional grid,
and are often represented using dots or squares
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.. Pixel: II

pixel 0.0

pixel 13.4

Pixel = Smallest Picture Element

Pixels are 
identified by
their position in 
a grid(two 
dimensional 
array),reference
d by its row(x), 
and column (y).
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.. Binary Image I

A binary image is a digital image that has only two possible
values for each pixel
Typically the two colors used for a binary image are black and
white though any two colors can be used
The color used for the object(s) in the image is the foreground
color while the rest of the image is the background color
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.. Binary Image II
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.. Bit Depth I

Color depth or bit depth is the number of bits used to
represent the color of a single pixel in a bitmapped image or
video frame buffer
This concept is also known as bits per pixel (bpp), particularly
when specified along with the number of bits used
Higher color depth gives a broader range of distinct colors
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.. Bit depth (color depth) I

.Color Depth..

......

1-bits ->
2-bits ->
4-bits ->
8-bits ->
16-bits ->
24-bits ->
32-bits ->

.Number of colors..

......

2 colors only, often black and white - binary image
4 colors, CGA, gray-scale
16 (Standard VGA)
256 (Super VGA, indexed color)
65,536 (High Color)
16,777,216 (True Color)
16,777,216 + alpha channel
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.. Two Main Types of Computer Graphics I

.. Computer Graphics.

Vector (Line Art)

.

PNG ???

.

AI

.

SVG

.

PDF

.
EPS

.

Bitmap (Raster)

.

JIG

.

JPEG

.

TIFF

.

RAW
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.. Bitmap Graphics

Bitmap graphics or raster graphics consist of pixels.
As the number of these pixels (dots) increases in the
measurement unit (inch or mm), the quality of the image
increases also, but always remember this is done on the
expense of the file size.
All scanned images are bitmaps, and all images from digital
cameras are bitmaps.
The format used in bitmaps in the order of preference are:
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.. Bitmap Graphics - Formats - 1

RAW
Is the king, but

not all publishers accept it because very few programs can
deal with it.

TIFF or TIF
Is always preferred, but

because there is no compression, the size of the resulting file
will be large.
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.. Bitmap Graphics - Formats - 2

JPEG - JPG
This is the third choice, the file size is small because of
compression.

Dot play with jpeg files because they are compressed and
liable for distortion. Only play with the tiff and then convert it
into jepg.
So for every image you should have two formats. The original
one in tiff (larger file size) and the second one in the jpeg
format (smaller file size) to be uploaded into the Internet.
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.. Bitmap Graphics - Formats - 3 - I

PNG
PNG is a special case being more nearer to vector graphics
format.
PNG is a bitmapped image format that employs lossless data
compression.
PNG is the only format which can be embedded in Microsoft
office PowerPoint or Word and also in Open Office.
The greatest advantage of PNG is its ability to support
transparency and transparent background.
Whenever, you need to export your vector graphics into
bitmaps you have to choose PNG
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.. Bitmap Graphics - Formats - 3 - II

Similarly, when you want to export your bitmaps e.g. TIFF or
JPEG into an image without background, you have to choose
PNG.
Tip: If you need to embed your graphs or bitmaps with
transparent background in Microsoft office or Open Office,
then you have only one choice “PNG”, otherwise you will not
need this format.

Dr Adel M Abdel-Azim Computer Graphics



. . . . . .

Objectives
Your Swiss Knife Software

Introduction to Computer Graphics
Two Main Types of Computer Graphics

Basic Skills

.. Bitmap Graphics - Formats - 4

JIF
Only used when you need animations in PowerPoint
presentations or in web pages.

PSD (Adobe Photoshop)
BMP

Is a windows format, useless and should not be used at all.

WMF
Is a windows format, useless and should not be used at all.
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.. Bitmap Graphics - Formats - 5

EMF
Enhanced metafile, useless

PIC
Is a mac format, useless and should not be used at all.

Many other formats eg .mix, emf, most of them are useless
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.. Vector Graphics

Instead of displaying the image on the monitor or paper in a
form of dots (pixels), the image is drawn on the screen or
paper each time utilizing mathematical formulas.
So this form of graphics is a non-pixel form (pixeless) and
hence resolution independent.
The resolution only depends on the capability of the computer
monitor or printer to draw the image.
The resulting image size is therefore very small (no pixels,
only mathematical algorithm).
The resulting image is of the highest possible quality.
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.. Vector Graphics

You can enlarge your image to fill the space between sky and
earth. There is no pixellation. The only limit is the capability
of your output device, monitor, data show, printer
This form is the one which is always preferred in scientific work
Put it in your head “always use vector graphics in your work,
whenever, there are no other choices, your second choice will
be tiff”.
.ai, .ps, .eps, .svg, cdr (CorelDRAW) .pdf are the standard
vector graphics format.
PDF is a special case as it is a vector graphics in which you
can embed bitmaps. So it is a mix.
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.. Scalable Vector Graphics (SVG)

Scalable Vector Graphics (SVG) is a file format for
two-dimensional vector graphics, both static and dynamic (i.e.
interactive or animated)
The SVG specification is an open standard that has been
under development by the World Wide Web Consortium
(W3C) since 1999
All major modern web browsers have at least some degree of
support and render SVG markup directly, including Mozilla
Firefox, Internet Explorer 9, Google Chrome, Opera, and Safari
SVG is the native format for Inkscape
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.. Inkscape

Inkscape is a free and Open Source vector graphics editor,
with capabilities similar to Illustrator, CorelDraw, or Xara X,
using the W3C standard Scalable Vector Graphics (SVG) file
format
Inkscape supports many advanced SVG features (markers,
clones, alpha blending, etc.)
It is very easy to edit nodes, perform complex path
operations, trace bitmaps and much more
Inkscape can be run on all platforms i.e. Windows, Linux and
MAC operating systems
Inkscape can be downloaded from http://inkscape.org/
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.. Vector Graphics Versus Raster (bitmap) graphics
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Working with Bitmap Graphics
Working with Bitmap Graphics
Working with Vector Graphics

.. Working with Bitmap Graphics I

What are the programs dealing with bitmap graphics

Adobe Photoshop and GIMP are the main programs that can deal
with bitmap graphics.

What is the best format I can use

TIFF is the preferred format for almost all publishers.
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.. Working with Bitmap Graphics I

What is the best resolution

For bimap images the resolution of 300 pixels/inch is preferred
For line arts, graphs and other images containing text, a
resolution of 900 pixels/inch is preferred if the image is to be
saved as a bitmap. The lines appear sharp even with when
zoomed in. Here we would still prefer a TIFF file as it is a
lossless format, while JPEG is a ‘lossy’ one.
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Working with Bitmap Graphics
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.. bitmap graphics

.What to Do With This Graph..

......

If I will copy or scan this graph it
should be:
1- TIFF
2- Resolution should > 900 PI

Dr Adel M Abdel-Azim Computer Graphics



. . . . . .

Objectives
Your Swiss Knife Software

Introduction to Computer Graphics
Two Main Types of Computer Graphics

Basic Skills

Working with Bitmap Graphics
Working with Bitmap Graphics
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.. bitmap graphics

What to Do With This Graph

...1 TIFF

...2 Resolution should be at least 900 PI
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.. Working with Bitmap Graphics I

How to convert color space

The color space suitable for most of the publishers is the
CMYB
In adobe Photoshop select image > mode > CMYB
GIMP does not support the CMYB natively yet, but no
problem leave the color space as it is
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.. Working with Bitmap Graphics I

How to adjust color, brightness and contrast

Refer to the manual of Photoshop or GIMP for detailed help on
this item
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.. Working with Bitmap Graphics I

Scalling versus Resizing

Scalling occurs when you edit an image in MS Word,
PowerPoint or DTP programs and adjust its dimensions
manually, either by dragging the image handle or by selecting
specific width and height.
The image in this case is said to be zoomed in or out.
If the image is zoomed out, the fine details of the image will
get smaller, (fonts become smaller, lines become thinner, cells
and nuclei becomes very small) and there is a possibility that
these internal details become invisible.
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.. Working with Bitmap Graphics II

If the image is zoomed in, the details will enlarge but the
image will be blurred and hazy.

In either case the magnification will change.
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.. Working with Bitmap Graphics I

Sizing or resizing (also called cropping)

Is done by selecting specific part of the image to be shown
and deleting the remaining part.
The magnification will not change and the file size will gets
smaller.
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.. Scalling Versus Cropping I

Original
Scaling Cropping

Figure: Scalling Versus Cropping
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.. Working with Bitmap Graphics I

.Never Ever..

......

allow a nonspecific software modify your image in any way. If you
need to resize, rescale, adjust brightness or contrast, use only a
specific image manipulation software such as Photoshop or GIMP.
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.. Working with Bitmap Graphics I

How to adjust image size

This is the most important skill that every researcher should know.
The steps for adjusting the print size of your image is as follows:

...1 Start by deciding if your image is to printed on A4 or B5
paper. You can know this by asking your publisher or by
getting information about your thesis from your colleagues or
university administration authorities.

...2 Decide whether your image will occupy one or two columns
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.. Working with Bitmap Graphics II
...3 For A4 paper, roughly, A4 paper width is 21cm. remove at

least 5cm for right and left margins. The remaining will be
21-5=17cm. If your image will occupy two columns then you
can make its width 16cm and if it should occupy 1 column,
then its width should be around 8cm.

...4 For B5 ISO paper, the width is 17.6cm and for B5 JIS, the
width is 18.2cm. We will use the least value which is the ISO
i.e. 17.6cm. the margins will be around 5cm. the remaining
part will be around 12cm, so two columns means an image
width of about 12cm and 1 column will be 6cm.
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.. Working with Bitmap Graphics III
...5 In GIMP, open your image, select Image > Print Size, select

your favorite unit by clicking on the tab and selecting more,
then select centimeters , then go to width and type your
required width and then click on the tab key in your keyboard
making sure that the chain of x resolution and y resolution are
linked and not broken. Finely, save your image.

...6 In Photoshop, open Image > Image Size > Document Size,
make sure that the chain of height and width is connected,
enter the required width in cm, make sure that the Resample
Image is unchecked, then click OK
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.. Working with Bitmap Graphics IV

...7 For histopathological images or images containing fine details,
try to crop the image instead of resizing. This will prevent
the image from being less magnified than the original one
with loss of final details. The cropping of course, should be to
the desired width.
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.. How to crop your image I

How to crop your image

Original image Image after cropping
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.. How to crop your image I

There are many reasons to crop an image; for example, fitting an
image to fill a frame, removing a portion of the background to
emphasize the subject, etc. To activate the crop tool. Click the

button in the Toolbox. This changes the cursor and allow you
to click and drag a rectangular shape.

Click on one corner of the desired crop area and drag your mouse
to create the crop rectangle. You don’t have to be accurate as you
can change the exact shape of the rectangle later.
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.. How to crop your image II

After completing the click and drag motion, a rectangle with
special regions is shown on the canvas. As the cursor is moved
over the different areas of the selected crop area, the cursor
changes. You can then drag the rectangle’s corners or edges to
change the dimensions of the selected area.
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.. How to crop your image III
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.. How to crop your image IV

As shown in the figure above, as the crop area is resized, the
dimensions and ratio are shown in the status bar. If you would like
to crop the image in a specific aspect ratio, such as a square, make
sure the tool options are visible ( Windows → Dockable Dialogs →
Tool Options). In the Tool Options, check the mark next to Fixed
and make sure the drop-down box next to it is set to Aspect Ratio.
You can now type the desired aspect ratio on the text box below,
such as “1:1”. You also have controls to change the aspect from
landscape to portrait.
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.. How to crop your image I

After you set the aspect ratio, drag one of the corners of the crop
rectangle to update it. The rectangle changes to the chosen ratio,
and when you drag it should maintain that ratio. You can also
adjust the position and the size of the crop area in the same dialog.
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Using Transparent Images on Word, PowerPoint, Web and in
Print

From Photoshop First, if you are working in Photoshop and going
to print or Web, check out the Export Transparent Image Wizard
located under the Help menu. It will ask you a series of questions
and export the image in the appropriate format. The image is
going to the Web.

You have three choices here: GIF, PNG, or ”faking it with JPEG.”
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.. Transparency I

PNG - PNG is a newer format developed to overcome many of
the limitations of GIF.
It supports high color and partial transparency using alpha
channels.
Although PNG has been around for a while now, the biggest
problem with it is that many people are still using older
browsers that do not support PNG, and even some modern
browsers do not support all the features of PNG.
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.. Transparency II

For instance, Microsoft Internet Explorer 6, which is still in
wide use today, does not support alpha transparency of PNG
images. Transparent PNG images do display properly in IE7,
however. More on PNG
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.. Transparency I

If your image will be used in a page layout application like
Lyx, InDesign, QuarkXpress, Scribus or PageMaker.

You have three choices here: Adobe native PSD format or TIFF
(alpha channels).

Adobe native PSD format: PSD retains transparency among
Adobe applications, so if you are working entirely in Adobe
applications, just use the Photoshop native PSD format with
transparency.
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Working with Bitmap Graphics
Working with Bitmap Graphics
Working with Vector Graphics

.. Transparency II
TIFF (Alpha Channels): Alpha channels are bitmap masks
that define transparency in shades of gray. When used in page
layout applications, the TIFF format is preferred for images
with alpha channel transparency.

How do I make parts of the image transparent ?

add an Alpha-channel to your image (using Layer >
Transparency > Add Alpha Channel)
select the Eraser-tool Eraser Tool and erase what you’d like to
get rid of or
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.. Transparency III

select a specific area using the Magic Wand Magic Wand (or
another selection tool) and use Edit > Clear (or press
CTRL+K) to make the selected area transparent
There is also an ColorToAlpha-plugin which takes one color
and makes all parts of the image with that color transparent.
Which is quite convenient...

Beware: not all graphics-formats support transparency.
Well-known formats that support transparency are GIF and PNG.
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.. How to crop your image I

How do I remove the Alpha-channel
(transparency-information) afterwards ?

Sometimes you want to get rid of the transparency-information in
your image. Of course you can save the image to a format that
does not support transparency, close the image and open it again.
But that’s not a very nice method. You’d better just flatten the
image: Layers > Flatten Image.
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.. Working with Vector Graphics I

What are the programs dealing with vector graphics

In MS Windows, Adobe Illustrator and CorelDraw

In Ubuntu - Debian, many, most famous is Inkscape and Dia
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.. Working with Vector Graphics I

Selecting proper font size

Not less than 12 pt

Selecting proper line thickness

Not less than 1 pt or better 1mm

Best format for vector graphics: PDF versus EPS

pdf format support gradient colors while eps not
svg is still in the beginning phase
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.. Working with Vector Graphics I

How to convert vector graphics into bitmaps

This is not necessary and you should not try to do this because
vector graphics are much more superior compared to bitmaps. If
your word processor does not support embedding vector graphics,
then you have to change it and use one which can do.

However, if you are obliged to do, most vector graphics software
can save as or export the image into “. png”. png format can be
embedded into almost all word processors.
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.. Working with Vector Graphics I

Excel Charts into EPS or PDF

The figures will eventually be published in a scientific journal

A lot of the journals need figures in EPS or PDF

...1 In Excel copy your graph and in Illustrator, past it.

...2 In Illustrator, ungroup the graph and work with formatting
issues (fonts, size, colors, etc.)

...3 In Illustrator, save it as EPS OR PDF, you can also export it
into PNG
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.. Working with Vector Graphics I

Excel Charts into EPS or PDF

A good solution, use Gnumeric instead of Excel

Gnumeric has a built in conversion into EPS or PDF

EPS or PDF can be open with Inkscape and re-adjusted
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.. Working with Vector Graphics I

How to create arrows in Inkscape

If you want to draw a black arrow with black arrow head, follow the
steps from 1 – 8. If you want to draw a colored arrow with colored
arrow head, you have to do the complete steps from 1 – 12.

...1 Select the ”Draw Bezier curves and straight lines” tool
(shift-F6)

...2 Line starting point: click mouse left

...3 Line ending point: double-click mouse left

...4 Open ”Fill and Stroke” dialog (shift-ctrl-F)
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.. Working with Vector Graphics II
...5 Click ”Stroke style” tab
...6 Line width: increase Width value
...7 Line type: ”Dashes” pull-down menu
...8 Arrow style: ”End Markers” and scroll down pull-down menu

for quite a length till you find ”Arrow2Mend”.
...9 Click ”Stroke paint” tab
...10 Select line color: adjust HSLA sliders or type-in RGBA value.

You now have a colored line with a black arrow head.
...11 Select your arrow and then select Object -> Transform
...12 Select Extension -> Modify Path -> Color Markers to Match

Stroke
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.. Short Message: I

.Take This Short Message..

......

...1 For Bitmap image, stick to TIFF

...2 For Bitmap image with transparency, stick to PNG

...3 For Vector image, stick to EPS or PDF
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.. Column Example 1: I

Column Number 1
soso and mimi

Column Number 2
toto and lolo

Dr Adel M Abdel-Azim Computer Graphics



. . . . . .

Objectives
Your Swiss Knife Software

Introduction to Computer Graphics
Two Main Types of Computer Graphics

Basic Skills

Working with Bitmap Graphics
Working with Bitmap Graphics
Working with Vector Graphics

.. Column with Block Example 1: I

a

aThis is my faculty label

.Observation 1..

......Do Not Eat Any Meat

.Observation 2..

......Do Not Eat Any Fool (Fasia Faba)

.Conclusion..

......You Will Die From Cachexia
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.. Column with Block Example 2: I

.Column 1 Header..

......Column 1 Body Text

.Column 2 Header..

......Column 2 Body Text
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